March 16, 2016 Frontpage Article, News 0 comment

Amex Announces 3rd Party Security Breach

The PCI-DSS security controls might need version 4.0 I guess…

At what point does the penalty associated with a breach achieve the desired effect?

2016-03-16 21_28_08-Kaspersky Lab (@kaspersky) _ Twitter